Field Link Office Will Not Open

Field Link Office Will Not Open

Issue

FieldLink will not open at all when launched. Nothing happens, you are not prompted to sign in for 365 days and no browser opens.


Cause

This issue can occur when FieldLink or its supporting Trimble components fail to properly initialize due to network security restrictions (firewalls, content filtering, or secured corporate networks) during installation or activation.


Resolution

Follow the steps below exactly in order:

  1. Uninstall all Trimble components

    • Uninstall Trimble FieldLink

    • Uninstall Trimble Product Activation

    • Uninstall Trimble Installation Manager

  2. Change network connection

    • Connect the tablet/PC to a mobile hotspot or

    • Use public/free Wi‑Fi (any network without strict security or filtering)

  3. Reinstall using the correct network

    • Download Trimble Installation Manager while connected to the hotspot or open network

    • Right‑click and Run as Administrator

  4. Install FieldLink

    • Use Trimble Installation Manager to install FieldLink

    • After installation, right‑click FieldLink and Run as Administrator on first launch

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